After upgrade to Joomla 3.2 from previous Joomla 3.* versions you might see the above error message in the backend, or, worse, you simply don't receive any e-mail notifications you usually do. And the site worked just fine before the upgrade!!

If you have registration enabled, or you use the site to interact with your visitors/customers the side effects can be really damaging - nobody gets any mails - and you evend don't see any notice about, until you began to dig for the causes, and, for example, try to send a message for yourself from backend. This potentially can roun your online business or community. Apparently everything is OK, all settings are correct, but the mails are simply not sent.

What's the cause and, more important, how you can fix it?

The cause is relatively simple: with arrival of Joomla 3.2 a new configuration setting was introduced. Open your configuration.php and look for this line:

public $mailonline = '1';

If the line, with value set to 0 or 1, one fo the valid choices, then the upgrade went smooth, and the line in question was added correctly to the site. And you must look elsevhere for a fix, the problem isn't caused by the upgrade to Joomla 3.2.

If the line is missing, or the value is set to 0, then you are among the large number of victims plagued by the problem. The fix is simple, if the line is missing, then go to Joomla Admin> System>Global Configuration and click Save - even changing nothing. This should fix the problem. If you have the above value set to 0, then go to Server tab in Global Configuration, Mail settings section, and change something there, for example, change the mailer from PHPMail to SMTP, save the settings, then change the setting back to the original value/the preferred setting wich worked before the upgrade, and save ti again.

This definitively will fix the problem.

0
0
0
s2sdefault
Category: Joomla Troubleshooter